[webkit-reviews] review denied: [Bug 40239] [Qt] ChromeClientQt.h has coding-style errors : [Attachment 87656] ChromeClientQt.h style fixes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 31 04:49:37 PDT 2011


Benjamin Poulain <benjamin at webkit.org> has denied Nancy Piedra
<nancy.piedra at nokia.com>'s request for review:
Bug 40239: [Qt] ChromeClientQt.h has coding-style errors
https://bugs.webkit.org/show_bug.cgi?id=40239

Attachment 87656: ChromeClientQt.h style fixes
https://bugs.webkit.org/attachment.cgi?id=87656&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=87656&action=review

> Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h:37
> +#include "RefCounted.h"

That should be #include <wtf/RefCounted.h>

> Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h:100
> +    virtual void addMessageToConsole(MessageSource, MessageType,
MessageLevel, const String& message,
> +					unsigned int lineNumber, const String&
sourceID);

You can put this on a single line, we don't limit line to 80 characters in
WebKit.

> Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h:152
> +    // see ChromeClient.h

You can remove that line.

> Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h:153
> +    // this is a hook for WebCore to tell us what we need to do with the
GraphicsLayers

Comments should be sentences, with a upper case at start, and a dot at the end.


> Source/WebKit/qt/WebCoreSupport/ChromeClientQt.h:200
> +    WebCore::KURL lastHoverURL;
> +    WTF::String lastHoverTitle;
> +    WTF::String lastHoverContent;

Where are those prefixed by the namespace? Aren't we in the WebCore namespace
already? And from the API is looks like WTF is also defined.


More information about the webkit-reviews mailing list