[webkit-reviews] review granted: [Bug 57326] Remove a bunch of duplicate code by adding some InlineIterator helper methods : [Attachment 87295] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 29 04:38:04 PDT 2011


Ryosuke Niwa <rniwa at webkit.org> has granted Eric Seidel <eric at webkit.org>'s
request for review:
Bug 57326: Remove a bunch of duplicate code by adding some InlineIterator
helper methods
https://bugs.webkit.org/show_bug.cgi?id=57326

Attachment 87295: Patch
https://bugs.webkit.org/attachment.cgi?id=87295&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=87295&action=review

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:1949
>		   if (!currentCharacterIsWS && previousCharacterIsWS) {
> -		       if (autoWrap && o->style()->breakOnlyAfterWhiteSpace())
{
> -			   lBreak.m_obj = o;
> -			   lBreak.m_pos = pos;
> -			   lBreak.m_nextBreakablePosition = nextBreakable;
> -		       }
> +		       if (autoWrap && o->style()->breakOnlyAfterWhiteSpace())
> +			   lBreak.moveTo(o, pos, nextBreakable);

We should just combine these two if statements.


More information about the webkit-reviews mailing list