[webkit-reviews] review granted: [Bug 56421] Devirtualize isContentEditable and isRichlyContentEditable : [Attachment 85891] Use enum instead of boolean

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 15 19:10:00 PDT 2011


Darin Adler <darin at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 56421: Devirtualize isContentEditable and isRichlyContentEditable
https://bugs.webkit.org/show_bug.cgi?id=56421

Attachment 85891: Use enum instead of boolean
https://bugs.webkit.org/attachment.cgi?id=85891&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=85891&action=review

> Source/WebCore/dom/Node.cpp:719
> +    // Ideally we'd call ASSERT!needsStyleRecalc()) here, but

Missing parenthesis. I know you just moved this, but still.

> Source/WebCore/dom/Node.cpp:724
> +    const Node* node = this;
> +    while (node) {

I’d write this as a for loop. That will work really well if both sides end up
doing node->parentNode, but it’s OK even without that.

    for (const Node* node = this; node; )


More information about the webkit-reviews mailing list