[webkit-reviews] review denied: [Bug 56389] Web Inspector: split InspectorAgent.populateScriptObjects into more granular agent-specific requests : [Attachment 85828] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 15 13:14:07 PDT 2011


Pavel Feldman <pfeldman at chromium.org> has denied Yury Semikhatsky
<yurys at chromium.org>'s request for review:
Bug 56389: Web Inspector: split InspectorAgent.populateScriptObjects into more
granular agent-specific requests
https://bugs.webkit.org/show_bug.cgi?id=56389

Attachment 85828: Patch
https://bugs.webkit.org/attachment.cgi?id=85828&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=85828&action=review

All looks good except for the getPreferredPanel. We should guess by the event /
action.

> Source/WebCore/inspector/Inspector.idl:37
> +	   void getPreferredPanel(out String panel);

I don't particularly like it. Inspector should determine preferred panel by
itself based on the event that is happening.

> Source/WebCore/inspector/InspectorAgent.cpp:459
>  void InspectorAgent::pushDataCollectedOffline()

It should be renamed to pushWorkers for now? Can we also push them from within
debugger::enable instead?

> Source/WebCore/inspector/InspectorDOMAgent.cpp:292
> +    m_document = 0;

Comment would be nice.

> Source/WebCore/inspector/front-end/ProfilesPanel.js:141
> +	   ProfilerAgent.isEnabled(function(error, value) {

Please declare a named function.


More information about the webkit-reviews mailing list