[webkit-reviews] review granted: [Bug 55416] Viewport no longer allows an auto value for "user-scalable" : [Attachment 85015] [PATCH] Convert userScalable back to float

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 8 00:57:56 PST 2011


Kenneth Rohde Christiansen <kenneth at webkit.org> has granted Joseph Pecoraro
<joepeck at webkit.org>'s request for review:
Bug 55416: Viewport no longer allows an auto value for "user-scalable"
https://bugs.webkit.org/show_bug.cgi?id=55416

Attachment 85015: [PATCH] Convert userScalable back to float
https://bugs.webkit.org/attachment.cgi?id=85015&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=85015&action=review

>> Source/WebCore/dom/ViewportArguments.cpp:175
>> +	if (args.userScalable == 0.0f)
> 
> Tests for true/false, null/non-null, and zero/non-zero should all be done
without equality comparisons.  [readability/comparison_to_zero] [5]

Our coding style actually says to always use 0 and not .0 or .0f. (Section
Floating point literals, item 1.)


More information about the webkit-reviews mailing list