[webkit-reviews] review granted: [Bug 55267] Add API to enumerate/delete files downloaded for <audio> and <video> : [Attachment 84918] Updated patch, with missing comma.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 7 09:52:12 PST 2011


Darin Adler <darin at apple.com> has granted Eric Carlson
<eric.carlson at apple.com>'s request for review:
Bug 55267: Add API to enumerate/delete files downloaded for <audio> and <video>
https://bugs.webkit.org/show_bug.cgi?id=55267

Attachment 84918: Updated patch, with missing comma.
https://bugs.webkit.org/attachment.cgi?id=84918&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=84918&action=review

> Source/WebCore/platform/graphics/MediaPlayer.cpp:743
> +    if (engines.isEmpty())
> +	   return;
> +
> +    unsigned count = engines.size();
> +    for (unsigned ndx = 0; ndx < count; ndx++) {
> +	   if (engines[ndx]->getSitesInMediaCache)
> +	       engines[ndx]->getSitesInMediaCache(sites);
> +    }

No need for a special case for an empty vector.

Should use size_t instead of unsigned.

I would name the local variable “size” to echo the name of the function.

We normally use “i” rather than “ndx” for this sort of thing.

Same comments for the other two functions below.


More information about the webkit-reviews mailing list