[webkit-reviews] review denied: [Bug 55685] Web Inspector: [Text editor] Do bisect to find visible chunks : [Attachment 84576] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 4 02:01:17 PST 2011


Pavel Feldman <pfeldman at chromium.org> has denied Andrey Adaikin
<aandrey at google.com>'s request for review:
Bug 55685: Web Inspector: [Text editor] Do bisect to find visible chunks
https://bugs.webkit.org/show_bug.cgi?id=55685

Attachment 84576: Patch
https://bugs.webkit.org/attachment.cgi?id=84576&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=84576&action=review

> Source/WebCore/inspector/front-end/TextViewer.js:408
> +    _findVisibleChunks: function(visibleFrom, visibleTo)

You should use insertionIndexForObjectInListSortedByFunction from utilities.js
(and you can rename it to binarySearch).

> Source/WebCore/inspector/front-end/TextViewer.js:661
> +	   return this._expandedLineRows ? this._expandedLineRows[0].offsetTop
: this.element.offsetTop;

What does this logic do?

> Source/WebCore/inspector/front-end/TextViewer.js:1580
> +	   return this._expandedLineRows ? this._expandedLineRows[0].offsetTop
: this.element.offsetTop;

ditto. Also, I see that gutter chunk and main chunk have a lot in common. This
does not sound right.


More information about the webkit-reviews mailing list