[webkit-reviews] review denied: [Bug 63757] Add optimised paths for a few maths functions : [Attachment 99375] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 30 15:43:17 PDT 2011


Gavin Barraclough <barraclough at apple.com> has denied Oliver Hunt
<oliver at apple.com>'s request for review:
Bug 63757: Add optimised paths for a few maths functions
https://bugs.webkit.org/show_bug.cgi?id=63757

Attachment 99375: Patch
https://bugs.webkit.org/attachment.cgi?id=99375&action=review

------- Additional Comments from Gavin Barraclough <barraclough at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=99375&action=review

> Source/JavaScriptCore/jit/JSInterfaceJIT.h:327
> +    inline JSInterfaceJIT::Jump JSInterfaceJIT::emitJumpIfNotDouble(int
virtualRegisterIndex, RegisterID base)

This is incorrect & unused, please remove.

> Source/JavaScriptCore/jit/SpecializedThunkJIT.h:74
> +	   Jump emitJumpIfArgumentNotDouble(int argument)

This is unused, please remove.

> Source/JavaScriptCore/jit/SpecializedThunkJIT.h:143
> +	   void callDoubleToDouble(double(*function)(double))

My understanding is that these will not obey this calling convention; please
make this a void* / FunctionPtr / etc.

> Source/JavaScriptCore/jit/ThunkGenerators.cpp:173
> +defineD2DWrapper(jsRound);

"D2D" seems to be more of an abbreviation than our coding standard really
agrees with, could we make this slightly verbier & clearer? - D2D ->
UnaryMathOp?


More information about the webkit-reviews mailing list