[webkit-reviews] review granted: [Bug 63295] Remove some unneeded functions from FrameLoader : [Attachment 98445] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 23 21:33:16 PDT 2011


Adam Barth <abarth at webkit.org> has granted  review:
Bug 63295: Remove some unneeded functions from FrameLoader
https://bugs.webkit.org/show_bug.cgi?id=63295

Attachment 98445: Patch
https://bugs.webkit.org/attachment.cgi?id=98445&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=98445&action=review

R+, modulo compile errors, of course.

> Source/WebCore/loader/FrameLoader.cpp:1570
> -    stopLoadingSubframes(clearProvisionalItemPolicy);
> +    for (RefPtr<Frame> child = m_frame->tree()->firstChild(); child; child =
child->tree()->nextSibling())
> +	   child->loader()->stopAllLoaders(clearProvisionalItemPolicy);

Inlining this function is very helpful.

> Source/WebCore/loader/FrameLoader.h:159
> -    // FIXME: Move this method to ResourceLoader with the rest of the
ResourceError accessors.
>      ResourceError cancelledError(const ResourceRequest&) const;

It seems like this function should be removed.	Are there clients of this
method that aren't better off calling the ResourceLoader version?


More information about the webkit-reviews mailing list