[webkit-reviews] review granted: [Bug 63300] Stop listening for CachedScript events as soon as notifyFinished() is called : [Attachment 98426] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 23 21:13:36 PDT 2011


Adam Barth <abarth at webkit.org> has granted James Simonsen
<simonjam at chromium.org>'s request for review:
Bug 63300: Stop listening for CachedScript events as soon as notifyFinished()
is called
https://bugs.webkit.org/show_bug.cgi?id=63300

Attachment 98426: Patch
https://bugs.webkit.org/attachment.cgi?id=98426&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=98426&action=review

It's too bad we don't have a good repro for this issue, but this patch looks
fine.

> Source/WebCore/dom/ScriptElement.cpp:316
>  void ScriptElement::notifyFinished(CachedResource* o)
>  {
>      ASSERT(!m_willBeParserExecuted);
>      ASSERT_UNUSED(o, o == m_cachedScript);

Can we rename "o" to something more readable, like "resource" ?


More information about the webkit-reviews mailing list