[webkit-reviews] review denied: [Bug 62709] [EFL] Add GraphicsContext3DEfl for WebGL and accelerated compositing : [Attachment 98116] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 22 07:44:49 PDT 2011


Leandro Pereira <leandro at profusion.mobi> has denied Hyowon Kim
<hw1008.kim at samsung.com>'s request for review:
Bug 62709: [EFL] Add GraphicsContext3DEfl for WebGL and accelerated compositing
https://bugs.webkit.org/show_bug.cgi?id=62709

Attachment 98116: Patch
https://bugs.webkit.org/attachment.cgi?id=98116&action=review

------- Additional Comments from Leandro Pereira <leandro at profusion.mobi>
View in context: https://bugs.webkit.org/attachment.cgi?id=98116&action=review

This looks like a huge wrapper class; isn't it possible to share most of this
code with other ports, as there are few references to Evas and such?

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:35
> +    bool renderDirectlyToEvasGLObject = (renderStyle ==
RenderDirectlyToHostWindow) ? true : false;

No need to use a ternary operator here; comparisons already returns a boolean.

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:142
> +    m_internal->bufferData(target, size, /* data */ 0, usage);

Is this comment really needed?

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:167
> +    m_internal->clearColor(r, g, b, a);

I'd use more descriptive names here.

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:177
> +    m_internal->clearStencil(s);

Ditto.


More information about the webkit-reviews mailing list