[webkit-reviews] review granted: [Bug 62899] [UNIX] Don't use WebCore::PluginPackage to get plugin information : [Attachment 97790] Patach rebased to current git master

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 20 09:57:35 PDT 2011


Martin Robinson <mrobinson at webkit.org> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 62899: [UNIX] Don't use WebCore::PluginPackage to get plugin information
https://bugs.webkit.org/show_bug.cgi?id=62899

Attachment 97790: Patach rebased to current git master
https://bugs.webkit.org/attachment.cgi?id=97790&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=97790&action=review

Looks good, but please take a look at the following suggestions before landing.


> Source/WebKit2/Shared/Plugins/Netscape/x11/NetscapePluginModuleX11.cpp:104
> +	   Vector<String> mime;

Maybe call this something like mimeTypeParts.

> Source/WebKit2/Shared/Plugins/Netscape/x11/NetscapePluginModuleX11.cpp:116
> +	   Vector<String> extensions;
> +	   if (mime.size() > 1) {
> +	       mime[1].split(UChar(','), false, extensions);
> +	       mimeInfo.extensions = extensions;

Can you just pass mimeInfo.extensions to the split call here?


More information about the webkit-reviews mailing list