[webkit-reviews] review granted: [Bug 62908] Optimization: avoid call to clearRect() when bgColor is valid when painting the root background in RenderBoxModelObject::paintFillLayerExtended : [Attachment 97655] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 17 17:50:14 PDT 2011


Darin Adler <darin at apple.com> has granted Una Sabovic <una.sabovic at palm.com>'s
request for review:
Bug 62908: Optimization: avoid call to clearRect() when bgColor is valid when
painting the root background in RenderBoxModelObject::paintFillLayerExtended
https://bugs.webkit.org/show_bug.cgi?id=62908

Attachment 97655: proposed patch
https://bugs.webkit.org/attachment.cgi?id=97655&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=97655&action=review

> Source/WebCore/rendering/RenderBoxModelObject.cpp:745
> +	   bool clearRect = false;

This local variable name sounds like “a rectangle that is clear” or a verb
phrase that means “clear a rectangle”, but it’s actually a boolean flag that
indicates whether we need to clear the background. I would name it
shouldClearBackground or mustClearBackground.

> Source/WebCore/rendering/RenderBoxModelObject.cpp:758
> +	       CompositeOperator compositeOp = clearRect ? CompositeCopy :
context->compositeOperation();

I’d name this “operation” rather than “compositeOp”.


More information about the webkit-reviews mailing list