[webkit-reviews] review denied: [Bug 58691] new-run-webkit-tests: sort test files "correctly" : [Attachment 97223] fix path sorting as well

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 16 11:43:36 PDT 2011


Tony Chang <tony at chromium.org> has denied Dirk Pranke <dpranke at chromium.org>'s
request for review:
Bug 58691: new-run-webkit-tests: sort test files "correctly"
https://bugs.webkit.org/show_bug.cgi?id=58691

Attachment 97223: fix path sorting as well
https://bugs.webkit.org/attachment.cgi?id=97223&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=97223&action=review

> Tools/Scripts/webkitpy/common/system/filesystem_mock.py:284
> +	   return (path[0:idx], path[idx:])

Shouldn't the second part be path[idx+1:] (i.e., without the slash)?  Also, do
you want to handle the case of multiple slashes (e.g., foo//bar)?  Nit: You can
omit the 0 in the first part of the tuple.

> Tools/Scripts/webkitpy/layout_tests/layout_package/manager.py:374
> +	       self._test_files_list.sort(key=lambda path: path_key(self._fs,
path))

Nit: It might be a bit easier to read if path_key() is just a member function
(then you don't have to use lambda).


More information about the webkit-reviews mailing list