[webkit-reviews] review granted: [Bug 61557] REGRESSION (r84166): recalcStyle for display:inline to display:none transition has complexity N^2 where N is the number of child Text nodes : [Attachment 96857] Use the containing block unless it is across a layer boundary

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jun 11 20:45:20 PDT 2011


Darin Adler <darin at apple.com> has granted mitz at webkit.org's request for review:
Bug 61557: REGRESSION (r84166): recalcStyle for display:inline to display:none
transition has complexity N^2 where N is the number of child Text nodes
https://bugs.webkit.org/show_bug.cgi?id=61557

Attachment 96857: Use the containing block unless it is across a layer boundary
https://bugs.webkit.org/attachment.cgi?id=96857&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=96857&action=review

> Source/WebCore/rendering/RenderText.cpp:1361
> +    RenderObject* cb = containingBlock();

I would much prefer a word or phrase to the acronym cb here. If “cb” is a good
name, then I suggest:

    RenderObject* containingBlock = this->containingBlock();

But if there is a better name for the local variable, then all the better.

> Source/WebCore/rendering/RenderText.cpp:1370
> +    // The containing block may be an ancestor of repaintContainer, but we
need to do a repaintContainer-relative repaint.
> +    if (repaintContainer && repaintContainer != cb &&
!cb->isDescendantOf(repaintContainer))
> +	       return
repaintContainer->clippedOverflowRectForRepaint(repaintContainer);

Wrong indentation on the body of this if.


More information about the webkit-reviews mailing list