[webkit-reviews] review granted: [Bug 62046] Allow existing AudioParams to use scheduled parameter changes : [Attachment 95956] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 3 13:42:09 PDT 2011


Kenneth Russell <kbr at google.com> has granted Chris Rogers
<crogers at google.com>'s request for review:
Bug 62046: Allow existing AudioParams to use scheduled parameter changes
https://bugs.webkit.org/show_bug.cgi?id=62046

Attachment 95956: Patch
https://bugs.webkit.org/attachment.cgi?id=95956&action=review

------- Additional Comments from Kenneth Russell <kbr at google.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=95956&action=review

Looks good to me. One minor comment.

> Source/WebCore/platform/audio/AudioBus.cpp:385
> +	       const float* source = sourceBus.channel(channelIndex)->data();
> +	       float* destination = channel(channelIndex)->data();
> +	       for (unsigned i = 0; i < numberOfGainValues; ++i)
> +		   destination[i] = source[i] * gainValues[i];
> +	   }
> +    } else if (sourceBus.numberOfChannels() == 1) {
> +	   const float* source = sourceBus.channel(0)->data();
> +	   for (unsigned channelIndex = 0; channelIndex < numberOfChannels();
++channelIndex) {
> +	       float* destination = channel(channelIndex)->data();
> +	       for (unsigned i = 0; i < numberOfGainValues; ++i)
> +		   destination[i] = source[i] * gainValues[i];

Would be nice to avoid the duplicated code.


More information about the webkit-reviews mailing list