[webkit-reviews] review granted: [Bug 60313] Add build logistics and plumbing for window.internals object. : [Attachment 94716] Dylib approach EXTREME rebased to HEAD

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 1 16:55:00 PDT 2011


Darin Adler <darin at apple.com> has granted Dimitri Glazkov (Google)
<dglazkov at chromium.org>'s request for review:
Bug 60313: Add build logistics and plumbing for window.internals object.
https://bugs.webkit.org/show_bug.cgi?id=60313

Attachment 94716: Dylib approach EXTREME rebased to HEAD
https://bugs.webkit.org/attachment.cgi?id=94716&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=94716&action=review

> Source/WebCore/bindings/js/JSDOMWrapper.h:53
> +    // An inline function cannot be the first non-abstract virtual function
declared
> +    // in the class as it results in the vtable being generated as a weak
symbol.
> +    virtual void noWeakVtable();

This technique is fine.

I would use a different name for the function that is more of a function name.
Maybe virtualFunctionToPreventWeakVtable.

> Source/WebCore/testing/Internals.cpp:33
> +    return adoptRef(new Internals());

I’d leave out the () here.


More information about the webkit-reviews mailing list