[webkit-reviews] review denied: [Bug 65158] [Chromium] Add better WebKit API for chrome.tabs.insertCSS extension API : [Attachment 101958] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 27 10:50:03 PDT 2011


Dave Hyatt <hyatt at apple.com> has denied Mihai Parparita <mihaip at chromium.org>'s
request for review:
Bug 65158: [Chromium] Add better WebKit API for chrome.tabs.insertCSS extension
API
https://bugs.webkit.org/show_bug.cgi?id=65158

Attachment 101958: Patch
https://bugs.webkit.org/attachment.cgi?id=101958&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=101958&action=review


So basically just change userSheets to documentUserSheets in the
CSSStyleSelector code. I think it's ok to use the generic m_userSheets in
Document, since it's more clear over there that they are per-document.

> Source/WebCore/css/CSSStyleSelector.cpp:432
> +				      CSSStyleSheet* pageUserSheet, const
Vector<RefPtr<CSSStyleSheet> >* pageGroupUserSheets, const
Vector<RefPtr<CSSStyleSheet> >* userSheets,

Rename userSheets to documentUserSheets here.

> Source/WebCore/css/CSSStyleSelector.cpp:489
> +    if (userSheets) {

Same here. Change userSheets to documentUserSheets.

> Source/WebCore/css/CSSStyleSelector.h:93
> +			    CSSStyleSheet* pageUserSheet, const
Vector<RefPtr<CSSStyleSheet> >* pageGroupUserSheets, const
Vector<RefPtr<CSSStyleSheet> >* userSheets,

Ditto.


More information about the webkit-reviews mailing list