[webkit-reviews] review denied: [Bug 64858] input[type='number'] with step="any" suffers from step mismatch. : [Attachment 101446] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 20 04:02:59 PDT 2011


Kent Tamura <tkent at chromium.org> has denied Shinya Kawanaka
<shinyak at google.com>'s request for review:
Bug 64858: input[type='number'] with step="any" suffers from step mismatch.
https://bugs.webkit.org/show_bug.cgi?id=64858

Attachment 101446: Patch
https://bugs.webkit.org/attachment.cgi?id=101446&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=101446&action=review


> Source/WebCore/html/HTMLInputElement.cpp:429
> +    // If step is not "any", the value should by aligned to the step.
> +    const AtomicString& stepString = fastGetAttribute(stepAttr);
> +    if (!equalIgnoringCase(stepString, "any")) {

This comment is not helpful. We avoid comments about "what we do here".  This
comment should be removed.
Also, this comment has a typo; by -> be.

In this case, you might want to make a function named alignValueForStep(...)
for readability.


More information about the webkit-reviews mailing list