[webkit-reviews] review denied: [Bug 64786] The value of a number input form continues to increase/decrease even if we disable the input form. : [Attachment 101288] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 19 02:22:46 PDT 2011


Kent Tamura <tkent at chromium.org> has denied Kentaro Hara <haraken at google.com>'s
request for review:
Bug 64786: The value of a number input form continues to increase/decrease even
if we disable the input form.
https://bugs.webkit.org/show_bug.cgi?id=64786

Attachment 101288: Patch
https://bugs.webkit.org/attachment.cgi?id=101288&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=101288&action=review


> LayoutTests/ChangeLog:20
> +	   Reviewed by NOBODY (OOPS!).

This line should be in the next of the bug URL.

> Source/WebCore/html/HTMLInputElement.cpp:795
> +    else if (attr->name() == disabledAttr)
> +	   m_inputType->disabledAttributeChanged();
> +    else if (attr->name() == readonlyAttr)
> +	   m_inputType->readonlyAttributeChanged();

This will make some regressions because
HTMLFormControlElement::parseMappedAttribute() won't be called for disabled and
readonly.

> Source/WebCore/html/TextFieldInputType.cpp:248
> +    m_innerSpinButton->stopRepeating();
> +}
> +
> +void TextFieldInputType::readonlyAttributeChanged()
> +{
> +    m_innerSpinButton->stopRepeating();

m_innerSpinButton can be NULL.

> Source/WebCore/html/shadow/TextControlInnerElements.cpp:336
> +void SpinButtonElement::stopRepeating()
> +{
> +    stopRepeatingTimer();
> +}

How about calling stopRepeatingTimer() in repeatingTimerFired()? If we do so,
we don't need to add disabledAttributeChanged() and readonlyAttribtueChanged().


More information about the webkit-reviews mailing list