[webkit-reviews] review granted: [Bug 64220] Scrollbar color heuristic needs to be hooked up in WebKit1 : [Attachment 101242] work around <rdar://problem/9797253>

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 18 18:25:35 PDT 2011


Darin Adler <darin at apple.com> has granted Tim Horton
<timothy_horton at apple.com>'s request for review:
Bug 64220: Scrollbar color heuristic needs to be hooked up in WebKit1
https://bugs.webkit.org/show_bug.cgi?id=64220

Attachment 101242: work around <rdar://problem/9797253>
https://bugs.webkit.org/attachment.cgi?id=101242&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=101242&action=review


I think the EWS failure was a false positive.

> Source/WebCore/platform/ScrollableArea.cpp:227
> +    if (horizontalScrollbar())
> +	  
ScrollbarTheme::nativeTheme()->updateScrollbarOverlayStyle(horizontalScrollbar(
));
> +    if (verticalScrollbar())
> +	  
ScrollbarTheme::nativeTheme()->updateScrollbarOverlayStyle(verticalScrollbar())
;
> +
> +    if (horizontalScrollbar())
> +	   horizontalScrollbar()->invalidate();
> +
> +    if (verticalScrollbar())
> +	   verticalScrollbar()->invalidate();

Could we merge these if statements for clarity?

> Source/WebCore/platform/mac/ScrollViewMac.mm:215
> +    switch (style) {
> +	   case ScrollbarOverlayStyleDark:
> +	       return NSScrollerKnobStyleDark;
> +	   case ScrollbarOverlayStyleLight:
> +	       return NSScrollerKnobStyleLight;
> +	   default:
> +	       return NSScrollerKnobStyleDefault;
> +    }

Same switch statement indentation problem.


More information about the webkit-reviews mailing list