[webkit-reviews] review granted: [Bug 64766] Crash under WebPage::platformDragEnded when dragging on Mac : [Attachment 101236] [PATCH] Prep Work
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Jul 18 16:55:37 PDT 2011
Darin Adler <darin at apple.com> has granted Brian Weinstein
<bweinstein at apple.com>'s request for review:
Bug 64766: Crash under WebPage::platformDragEnded when dragging on Mac
https://bugs.webkit.org/show_bug.cgi?id=64766
Attachment 101236: [PATCH] Prep Work
https://bugs.webkit.org/attachment.cgi?id=101236&action=review
------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=101236&action=review
> Source/WebCore/page/DragClient.h:70
> + // Mac specific helper functions to allow access to functionality in
webkit -- such as
I’d put a hyphen in Mac-specific. And I’d capitalize WebKit. And I’d try to
make it grammatical:
... functionality in WebKit, for use in places such as
web archives and NSPasteboard extras.
Maybe rewrite it entirely for clarity.
> Source/WebCore/page/DragClient.h:78
> + virtual void declareAndWriteDragImage(NSPasteboard *, DOMElement*,
NSURL *, NSString*, Frame *) {}
> #endif
>
> - virtual ~DragClient() {};
> + virtual void dragEnded() {}
> +
> + virtual ~DragClient() {}
Our style is to put a space between the braces "{ }".
More information about the webkit-reviews
mailing list