[webkit-reviews] review denied: [Bug 51897] Escape should clear search field : [Attachment 100927] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 14 22:44:08 PDT 2011


Kent Tamura <tkent at chromium.org> has denied Kentaro Hara <haraken at google.com>'s
request for review:
Bug 51897: Escape should clear search field
https://bugs.webkit.org/show_bug.cgi?id=51897

Attachment 100927: Patch
https://bugs.webkit.org/attachment.cgi?id=100927&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=100927&action=review


r- because of patch conflicts.

> LayoutTests/fast/forms/input-search-press-escape-key.html:65
> +}
> +

Please show a manual test instruction if there is no layoutTestController or
eventSender.

> Source/WebCore/html/SearchInputType.cpp:107
> +	   if (input->disabled() || input->readOnly())
> +	       return;

TextFieldInputType::handleKeydownEvent() should be called even if the input is
not editable.
It doesn't affect any behavior.  It's for consistency.


More information about the webkit-reviews mailing list