[webkit-reviews] review denied: [Bug 64582] JSC JIT does not inline GC allocation fast paths : [Attachment 100926] the patch (fix style)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 14 21:58:35 PDT 2011


Oliver Hunt <oliver at apple.com> has denied Filip Pizlo <fpizlo at apple.com>'s
request for review:
Bug 64582: JSC JIT does not inline GC allocation fast paths
https://bugs.webkit.org/show_bug.cgi?id=64582

Attachment 100926: the patch (fix style)
https://bugs.webkit.org/attachment.cgi?id=100926&action=review

------- Additional Comments from Oliver Hunt <oliver at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=100926&action=review


r- but basically just because of the code duplication.	Would be good to get
32bit going as well.

> Source/JavaScriptCore/jit/JITOpcodes.cpp:352
> +    // remove the object from the free list
> +    loadPtr(Address(regT0), regT1);
> +    storePtr(regT1, &sizeClass->firstFreeCell);
> +    
> +    // initialize the object's vtable
> +    storePtr(ImmPtr(m_globalData->jsFinalObjectVPtr), Address(regT0));
> +    
> +    // initialize the object's structure
> +    storePtr(ImmPtr(m_codeBlock->globalObject()->emptyObjectStructure()),
Address(regT0, JSCell::structureOffset()));
> +    
> +    // initialize the inheritor ID
> +    storePtr(ImmPtr(0), Address(regT0, JSObject::offsetOfInheritorID()));
> +    
> +    // initialize the object's property storage pointer
> +    addPtr(Imm32(sizeof(JSObject)), regT0, regT1);

I think all of this could be hoisted into a separate helper function, rather
than duplicating the code in op_create_this, well i guess with the exception of
the initial structure


More information about the webkit-reviews mailing list