[webkit-reviews] review denied: [Bug 64337] [EFL] Refactor scheduleDispatchFunctionsOnMainThread to fix crash. : [Attachment 100596] pipe_approach

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 12 18:06:07 PDT 2011


Leandro Pereira <leandro at profusion.mobi> has denied Ryuan Choi
<ryuan.choi at samsung.com>'s request for review:
Bug 64337: [EFL] Refactor scheduleDispatchFunctionsOnMainThread to fix crash.
https://bugs.webkit.org/show_bug.cgi?id=64337

Attachment 100596: pipe_approach
https://bugs.webkit.org/attachment.cgi?id=100596&action=review

------- Additional Comments from Leandro Pereira <leandro at profusion.mobi>
View in context: https://bugs.webkit.org/attachment.cgi?id=100596&action=review


This looks better, but I'm not familiar with Ecore_Pipe; I'll check the
documentation (and code) tomorrow and do a proper informal review. In the
meantime, informal r- for the reasons below.

> Source/JavaScriptCore/wtf/efl/MainThreadEfl.cpp:43
> +static void deletePipe();
> +static Ecore_Pipe* pipe;

You could implement the needed OwnPtrEfl function for Ecore_Pipe, and get rid
of deletePipe() (and the associated atexit() call below). Also, you should use
a better name than simply "pipe".


More information about the webkit-reviews mailing list