[webkit-reviews] review granted: [Bug 64037] Add roll-chromium-deps command to sheriff-bot : [Attachment 99894] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 6 15:37:59 PDT 2011


Eric Seidel <eric at webkit.org> has granted Adam Barth <abarth at webkit.org>'s
request for review:
Bug 64037: Add roll-chromium-deps command to sheriff-bot
https://bugs.webkit.org/show_bug.cgi?id=64037

Attachment 99894: Patch
https://bugs.webkit.org/attachment.cgi?id=99894&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=99894&action=review

OK.

> Tools/Scripts/webkitpy/tool/bot/irc_command.py:135
> +	   if revision:
> +	       tool.irc().post("%s: Rolling Chromium DEPS to r%s" % (nick,
revision))
> +	   else:
> +	       tool.irc().post("%s: Rolling Chromium DEPS last-known good
revision" % nick)

I would have probably used:
roll_target = "r%" % revision if revision else "last-known good revision"
tool.irc().post("%s Rolling Chromium DEPS to %s" % (nick, roll_target))

> Tools/Scripts/webkitpy/tool/bot/irc_command.py:142
> +	       match = re.search(r"Current Chromium DEPS revision \d+ is newer
than \d+\.", e.output)

Does this need to be multi-line?

> Tools/Scripts/webkitpy/tool/bot/irc_command.py:144
> +		   tool.irc().post("%s: %s" % (nick, match.group(0)))

You could name your groups for clarity.

> Tools/Scripts/webkitpy/tool/bot/irc_command.py:145
> +		   return

return None will exit 0, is that what you want?  Oh, I guess this is a IRC
command, so it will just not say anthing.  return None is still probably more
explicit than return.  Not sure it maters.

> Tools/Scripts/webkitpy/tool/bot/irc_command.py:151
> +	       bug_id = parse_bug_id(e.output)
> +	       if bug_id:
> +		   bug_url = tool.bugs.bug_url_for_bug_id(bug_id)
> +		   tool.irc().post("%s: Ugg...	Might have created %s" % (nick,
bug_url))

Wish we could share this somehow....


More information about the webkit-reviews mailing list