[webkit-reviews] review granted: [Bug 52982] SVG is missing to-animation support for Path : [Attachment 79977] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 25 01:35:40 PST 2011


Nikolas Zimmermann <zimmermann at kde.org> has granted Dirk Schulze
<krit at webkit.org>'s request for review:
Bug 52982: SVG is missing to-animation support for Path
https://bugs.webkit.org/show_bug.cgi?id=52982

Attachment 79977: Patch
https://bugs.webkit.org/attachment.cgi?id=79977&action=review

------- Additional Comments from Nikolas Zimmermann <zimmermann at kde.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=79977&action=review

Looks great, r=me with two comments:

> Source/WebCore/svg/SVGPathByteStream.h:54
> +    PassOwnPtr<SVGPathByteStream> copySVGPathByteStream()

I'd name it copy(), as it's a member of SVGPathByteStream...

> Source/WebCore/svg/SVGPathByteStream.h:58
> +	   OwnPtr<SVGPathByteStream> copy = SVGPathByteStream::create();
> +	   copy->m_data = m_data;
> +	   return copy.release();

PassOwnPtr<SVGPathByteStream> copy()
{
    return SVGPathByteStream::create(m_data);
}

Then add a private SVGPathByteStream constructor, taking a Data& reference:
private:
SVGPathByteStream(Data& data)
    : m_data(data)
{
}

That's much cleaner and avoids a OwnPtr -> PassOwnPtr conversion.


More information about the webkit-reviews mailing list