[webkit-reviews] review granted: [Bug 52848] Keep track of the latest update timestamp in the backing store : [Attachment 79659] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 20 16:05:24 PST 2011


Darin Adler <darin at apple.com> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 52848: Keep track of the latest update timestamp in the backing store
https://bugs.webkit.org/show_bug.cgi?id=52848

Attachment 79659: Patch
https://bugs.webkit.org/attachment.cgi?id=79659&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=79659&action=review

> Source/WebKit2/Shared/UpdateInfo.h:44
> +    UpdateInfo() : timestamp(0) { }

Is 0 the best thing for a not-set value? Maybe NaN or -infinity? Or maybe 0 is
OK.

> Source/WebKit2/UIProcess/BackingStore.cpp:47
> +    , m_latestUpdateTimestamp(0)

Is 0 the best way to represent this? I guess a date in the distant past is OK,
but for that we could also use -infinity. Or maybe 0 is OK.

> Source/WebKit2/UIProcess/BackingStore.cpp:69
> +    platformIncorporateUpdate(bitmap.get(), updateInfo);

I kinda hate using platform as a function name prefix. Especially since this is
not the same function as incorporateUpdate -- it’s only a part of the work. I
would prefer this have the same name the function would have if there was only
one platform.


More information about the webkit-reviews mailing list