[webkit-reviews] review denied: [Bug 52680] [chromium] Notify WebViewClient when spellcheck state changes : [Attachment 79425] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 19 08:41:27 PST 2011


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied  review:
Bug 52680: [chromium] Notify WebViewClient when spellcheck state changes
https://bugs.webkit.org/show_bug.cgi?id=52680

Attachment 79425: Patch
https://bugs.webkit.org/attachment.cgi?id=79425&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=79425&action=review

> Source/WebKit/chromium/public/WebViewClient.h:191
> +    virtual void continuousSpellCheckingEnabledStateChanged() { }

This function name is a real mouthful.	We also have a naming convention for
methods like this, where they start with "didChange" instead.

So, didChangeContinuousSpellCheckingEnabledState would be more consistent.  I
still find this method name to be overly verbose.

Also, this method is on WebViewClient.h, and yet the corresponding methods to
query the "spellchecking" state lives on WebFrame.
shouldn't this notification method live on WebFrameClient, then?


More information about the webkit-reviews mailing list