[webkit-reviews] review granted: [Bug 52331] Get the new drawing area painting to the screen : [Attachment 78750] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 12 15:55:49 PST 2011


Sam Weinig <sam at webkit.org> has granted Anders Carlsson <andersca at apple.com>'s
request for review:
Bug 52331: Get the new drawing area painting to the screen
https://bugs.webkit.org/show_bug.cgi?id=52331

Attachment 78750: Patch
https://bugs.webkit.org/attachment.cgi?id=78750&action=review

------- Additional Comments from Sam Weinig <sam at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=78750&action=review

> WebKit2/UIProcess/mac/BackingStoreMac.mm:51
> +    size_t sizeInBytes =
CGBitmapContextGetBytesPerRow(m_bitmapContext.get()) *
CGBitmapContextGetHeight(m_bitmapContext.get());
> +    RetainPtr<CGDataProviderRef> dataProvider(AdoptCF,
CGDataProviderCreateWithData(0, CGBitmapContextGetData(m_bitmapContext.get()),
sizeInBytes, 0));
> +							 
CGBitmapContextGetHeight(m_bitmapContext.get()),
> +							 
CGBitmapContextGetBitsPerPixel(m_bitmapContext.get()),
> +							 
CGBitmapContextGetBytesPerRow(m_bitmapContext.get()),
> +							 
CGBitmapContextGetColorSpace(m_bitmapContext.get()),
> +							 
CGBitmapContextGetBitmapInfo(m_bitmapContext.get()),
> +							  dataProvider.get(),
0, false, kCGRenderingIntentDefault));
> +
> +    CGFloat imageWidth = CGImageGetWidth(image.get());

We should move this code to a shared function at somepoint. Please add a fixme.


More information about the webkit-reviews mailing list