[webkit-reviews] review denied: [Bug 30179] [Qt] Need a way to inform the application when a Netscape plugin is created or deleted. : [Attachment 78454] Fix style problems

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 12 05:50:36 PST 2011


Simon Hausmann <hausmann at webkit.org> has denied Viatcheslav Ostapenko
<ostapenko.viatcheslav at nokia.com>'s request for review:
Bug 30179: [Qt] Need a way to inform the application when a Netscape plugin is
created or deleted.
https://bugs.webkit.org/show_bug.cgi?id=30179

Attachment 78454: Fix style problems
https://bugs.webkit.org/attachment.cgi?id=78454&action=review

------- Additional Comments from Simon Hausmann <hausmann at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=78454&action=review

Looks okay to me, I think this will be the last round of review. However please
move the exported function into PluginViewSymbian.cpp, as this is a feature
currently only implemented and needed in this one particular use-case on
Symbian.

> WebKit/qt/Api/qwebpage.cpp:146
> +typedef void (*_qt_page_plugin_created)(QWebFrame*, void*, void*); // frame,
plugin instance, plugin functions
> +_qt_page_plugin_created qt_page_plugin_created = 0;
> +QWEBKIT_EXPORT void qt_setPluginCreatedCallback(_qt_page_plugin_created cb)
> +{
> +    qt_page_plugin_created = cb;
> +}

This should go into PluginViewSymbian.cpp. The variable then also becomes
either a class variable or local to the compilation unit (static).

Also, please rename qt_setPluginCreatedCallback to
qtwebkit_setPluginCreatedCallback.


More information about the webkit-reviews mailing list