[webkit-reviews] review granted: [Bug 52172] Max area bound needed in creation of IOSurface in ImageBufferCG.cpp : [Attachment 78589] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 11 13:41:06 PST 2011


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Matthew Delaney
<mdelaney at apple.com>'s request for review:
Bug 52172: Max area bound needed in creation of IOSurface in ImageBufferCG.cpp
https://bugs.webkit.org/show_bug.cgi?id=52172

Attachment 78589: Patch
https://bugs.webkit.org/attachment.cgi?id=78589&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=78589&action=review

r=me with some test cleanup.

> LayoutTests/ChangeLog:11
> +	   * fast/canvas/height.largeValues-expected.txt: Added.
> +	   * fast/canvas/height.largeValues.html: Added.
> +	   * fast/canvas/width.largeValues-expected.txt: Added.
> +	   * fast/canvas/width.largeValues.html: Added.

I see no reason to have separate tests for height and width. Also, the '.'
naming convention isn't used in fast/ tests normally.

> LayoutTests/fast/canvas/height.largeValues.html:15
> +canvas.height = 1000;
> +if (canvas.height ==1000)
> +	testPassed("height == 1000");
> +else
> +	testFailed("height == 1000");

Does this really exercise the underlying ImageBuffer code? How about trying to
draw a pixel at 0, 999 and then reading it back?


More information about the webkit-reviews mailing list