[webkit-reviews] review granted: [Bug 52054] [GTK] Port progressbar painting to GtkStyleContext : [Attachment 78224] Use GtkStyleContext API to paint progressbars

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jan 8 12:43:03 PST 2011


Martin Robinson <mrobinson at webkit.org> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 52054: [GTK] Port progressbar painting to GtkStyleContext
https://bugs.webkit.org/show_bug.cgi?id=52054

Attachment 78224: Use GtkStyleContext API to paint progressbars
https://bugs.webkit.org/attachment.cgi?id=78224&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=78224&action=review

Looks great, but please see below before landing this.

> WebCore/platform/gtk/RenderThemeGtk3.cpp:369
> +static const int progressActivityBlocks = 5;
> +static const int progressAnimationFrames = 10;
> +static const double progressAnimationInterval = 0.125;

Include a comment before these values which explains where they originate from.


> WebCore/platform/gtk/RenderThemeGtk3.cpp:411
> +	   double progress = renderProgress->animationProgress();

I think this should be called animationProgress, to avoid confusing it with the
actual progress position. Please just rename before landing. Thanks!


More information about the webkit-reviews mailing list