[webkit-reviews] review granted: [Bug 51927] Unify string table adding in AtomicString : [Attachment 78001] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 6 14:52:45 PST 2011


Darin Adler <darin at apple.com> has granted Patrick R. Gansterer
<paroga at paroga.com>'s request for review:
Bug 51927: Unify string table adding in AtomicString
https://bugs.webkit.org/show_bug.cgi?id=51927

Attachment 78001: Patch
https://bugs.webkit.org/attachment.cgi?id=78001&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=78001&action=review

> Source/JavaScriptCore/ChangeLog:11
> +	   * wtf/text/AtomicString.cpp:
> +	   (WTF::addIntoStringTable):
> +	   (WTF::AtomicString::add):
> +	   (WTF::AtomicString::fromUTF8):

Change logs are much better when you add some per-function comments. It takes a
few more minutes, but is better for the project long-term.

> Source/JavaScriptCore/wtf/text/AtomicString.cpp:78
> +static inline PassRefPtr<StringImpl> addIntoStringTable(const T& value)

I would suggest calling this “addToStringTable” rather than
“addIntoStringTable”.


More information about the webkit-reviews mailing list