[webkit-reviews] review denied: [Bug 51811] Merge m_height and m_width members of ImageData into a common m_size member : [Attachment 77799] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 3 03:56:00 PST 2011


Andreas Kling <kling at webkit.org> has denied Renata Hodovan <reni at webkit.org>'s
request for review:
Bug 51811: Merge m_height and m_width members of ImageData into a common m_size
member
https://bugs.webkit.org/show_bug.cgi?id=51811

Attachment 77799: Patch
https://bugs.webkit.org/attachment.cgi?id=77799&action=review

------- Additional Comments from Andreas Kling <kling at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=77799&action=review

> WebCore/html/ImageData.h:46
> +    unsigned width() const { return m_size.width(); }
> +    unsigned height() const { return m_size.height(); }

The getter return type should at the very least match the member variable's
type.
Setting r- for this, but please explain why the overall change is correct
before (or as part of) the next iteration.


More information about the webkit-reviews mailing list