[webkit-reviews] review granted: [Bug 55159] Variable-sized allocation (but still capped at 64 bytes) : [Attachment 83683] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 24 11:51:17 PST 2011


Darin Adler <darin at apple.com> has granted Geoffrey Garen <ggaren at apple.com>'s
request for review:
Bug 55159: Variable-sized allocation (but still capped at 64 bytes)
https://bugs.webkit.org/show_bug.cgi?id=55159

Attachment 83683: Patch
https://bugs.webkit.org/attachment.cgi?id=83683&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=83683&action=review

> Source/JavaScriptCore/runtime/JSCell.h:438
> +	   if (!result)
> +	       result = allocateSlowCase(bytes);
> +	   ASSERT(result);
> +	   return result;

I like early return better than this construction.

> Source/JavaScriptCore/runtime/MarkedSpace.h:108
> -	   SizeClass m_sizeClass;
> +	   SizeClass m_precise[preciseCount];

I don’t think that an adjective like precise makes a good name for a data
member.


More information about the webkit-reviews mailing list