[webkit-reviews] review denied: [Bug 54580] [chromium] Enable media elements statistics support in chromium : [Attachment 82828] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 17 23:41:38 PST 2011


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Steve Lacey
<sjl at chromium.org>'s request for review:
Bug 54580: [chromium] Enable media elements statistics support in chromium
https://bugs.webkit.org/show_bug.cgi?id=54580

Attachment 82828: Patch
https://bugs.webkit.org/attachment.cgi?id=82828&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=82828&action=review

> Source/WebKit/chromium/public/WebMediaPlayer.h:132
> +    virtual unsigned long decodedFrames() const = 0;

nit: webkit style is to just use "unsigned" instead of "unsigned long"

nit: are "decodedFrames" and "droppedFrames" meant to return counts of
{decoded,dropped}Frames?
if so, the names of these methods could be improved.  as is, it sounds like the
methods should
be returning sets of frames--one set of decoded frames and one set of dropped
frames, but clearly
that's not what they do since they return integers.

How about one of these names?

  {count,number}Of{Decoded,Dropped}Frames
  {decoded,dropped}FrameCount

> Source/WebKit/chromium/src/WebMediaPlayerClientImpl.cpp:453
> +unsigned long WebMediaPlayerClientImpl::decodedFrames() const

looks like the WebCore interfaces have the same naming problem.


More information about the webkit-reviews mailing list