[webkit-reviews] review granted: [Bug 54421] Add initial support for per-origin quotas to IndexedDB : [Attachment 82509] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 15 14:00:36 PST 2011


Darin Fisher (:fishd, Google) <fishd at chromium.org> has granted Jeremy Orlow
<jorlow at chromium.org>'s request for review:
Bug 54421: Add initial support for per-origin quotas to IndexedDB
https://bugs.webkit.org/show_bug.cgi?id=54421

Attachment 82509: Patch
https://bugs.webkit.org/attachment.cgi?id=82509&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=82509&action=review

> Source/WebKit/chromium/public/WebIDBFactory.h:60
> +    static const long long DefaultQuota = -1;

nit: use variable naming: fooBar

maybe these variables should be named differently so that it is more apparent
that they should be passed in for the "maximumSize" field?

how about renaming maximumSize to quota?  alternatively, you could rename the
constants to defaultMaximumSize and unlimitedMaximumSize.

also, since this expression of quota might appear in other WebKit storage APIs,

maybe we should have some generalized expression of quota?  maybe these
constants
should be pulled out to a separate header file?


More information about the webkit-reviews mailing list