[webkit-reviews] review granted: [Bug 52417] Add EditorClient callbacks to override isDOMPasteAllowed and javaScriptCanAccessClipboard : [Attachment 82415] Fixed per Adam's comment

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 14 22:38:17 PST 2011


Adam Barth <abarth at webkit.org> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 52417: Add EditorClient callbacks to override isDOMPasteAllowed and
javaScriptCanAccessClipboard
https://bugs.webkit.org/show_bug.cgi?id=52417

Attachment 82415: Fixed per Adam's comment
https://bugs.webkit.org/attachment.cgi?id=82415&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=82415&action=review

> Source/WebKit2/WebProcess/WebCoreSupport/WebEditorClient.cpp:256
> +    notImplemented();

These probably don't need notImplemented().  These are perfectly fine
implementations.

> Source/WebKit2/WebProcess/WebCoreSupport/WebEditorClient.h:78
> +    virtual bool canCopyCut(bool defaultValue) const;
> +    virtual bool canPaste(bool defaultValue) const;

Are these the same semantically as the functions below?  If not, consider
renaming them to allowPaste, etc.


More information about the webkit-reviews mailing list