[webkit-reviews] review canceled: [Bug 42629] [QT] Implement client based geolocation for qtport : [Attachment 81688] first-look patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 10 09:39:49 PST 2011


Mahesh Kulkarni <mahesh.kulkarni at nokia.com> has canceled Mahesh Kulkarni
<mahesh.kulkarni at nokia.com>'s request for review:
Bug 42629: [QT] Implement client based geolocation for qtport
https://bugs.webkit.org/show_bug.cgi?id=42629

Attachment 81688: first-look patch
https://bugs.webkit.org/attachment.cgi?id=81688&action=review

------- Additional Comments from Mahesh Kulkarni <mahesh.kulkarni at nokia.com>
Updated patch as per comment #3.

>From previous patch, 

-----------------------------

Patch implements,
    1) Enables ENABLE_CLIENT_BASED_GEOLOCATION for QtWebkit
    2) Qt's WebCore::GeolocationClient class GeolocationClientQt and assigns to
WebCore::PageClient for Geolocation instance.
    3) Code to initialize and listening to QtMobility's geolocation service
code is moved from Source/WebCore/platform/qt/GeolocationServiceQt.cpp to
Source/WebKit/qt/WebCoreSupport/GeolocationClientQt.cpp
    4) Permission API's are moved to WebCore::GeolocationClient so the
QtWebkit's GeolocationPermissionClientQt calls moved from ChromeClientQt.cpp to
GeolocationClientQt.cpp


What patch doesnt implement/planned to implement, (Raise a new bug probably and
mark it blocked to this bug? to keep the patch simple/easy to review)
    1) LayoutTest implementation for Client-Based geolocation. Need to
implement new Mock-Client-based test classes. Disabled Geolocation cases in
Skipped file till then.
    2) Cleaning up DRT Qt code related to old geolocation test framework. 
    3) raise a separate bug to remove/clean up
GeolocationPermissionClientQt.cpp/.h code and move the logic to
GeolocationClientQt.cpp itself.
    4) page/ChromeClient.h functions, requestGeolocationPermissionForFrame and
cancelGeolocationPermissionRequestForFrame can be disabled/put under
!non-client implementation for more readability. Will raise a separate bug for
this as well.


Please provide your first-hand review comments before I can submit the final
patch before above changes. (If chosen not to worry about patch size :)

--------------------------------


More information about the webkit-reviews mailing list