[webkit-reviews] review denied: [Bug 53564] Make canHaveChildrenForEditing more efficient : [Attachment 81041] added canContainPosition instead of canHaveChildrenForEditing
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Feb 9 20:19:21 PST 2011
Eric Seidel <eric at webkit.org> has denied Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 53564: Make canHaveChildrenForEditing more efficient
https://bugs.webkit.org/show_bug.cgi?id=53564
Attachment 81041: added canContainPosition instead of canHaveChildrenForEditing
https://bugs.webkit.org/attachment.cgi?id=81041&action=review
------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=81041&action=review
It also seems like this "can contain" concept is very similar to being a
replaced element in the renderer. Are we sure they're not identical?
> Source/WebCore/dom/Document.h:440
> + bool canContainPosition() const { return true; }
Since position isn't a DOM concept (yet), I think we should rename this to talk
about range end points. canContainRangeEndPoint would be fine. You had some
other suggestions over IRC which sounded fine too.
> Source/WebCore/editing/htmlediting.h:87
> +inline bool canHaveChildrenForEditing(const Node* node)
Should have a FIXME about renmaing this function, since the name makes no sense
to me. SEems to have nothing to do with children.
More information about the webkit-reviews
mailing list