[webkit-reviews] review granted: [Bug 53840] nrwt multiprocessing: conclude refactoring of dump_render_tree_thread and single_test_runner : [Attachment 81597] fix baseline for merge

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 8 16:58:14 PST 2011


Tony Chang <tony at chromium.org> has granted Dirk Pranke <dpranke at chromium.org>'s
request for review:
Bug 53840: nrwt multiprocessing: conclude refactoring of
dump_render_tree_thread and single_test_runner
https://bugs.webkit.org/show_bug.cgi?id=53840

Attachment 81597: fix baseline for merge
https://bugs.webkit.org/attachment.cgi?id=81597&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=81597&action=review

Aside from the huge try/finally, seems fine.

>
Tools/Scripts/webkitpy/layout_tests/layout_package/dump_render_tree_thread.py:1
93
> +	   try:
> +	       while True:
> +		   if self._canceled:
> +		       _log.debug('Testing cancelled')

Having a huge try/finally block is hard to follow.  I would prefer splitting
the code into a separate function and having the try/finally be around just the
function call (still hard to follow, but makes the whitespace/indention easier
to see).

Alternately, the try/finally part doesn't seem related to the refactoring. 
Maybe it should be in a separate patch?


More information about the webkit-reviews mailing list