[webkit-reviews] review denied: [Bug 75082] REGRESSION(r102987): Fix the filename prefix of the generated empty .h and .cpp files for [Supplemental] IDLs : [Attachment 120314] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 22 09:27:57 PST 2011


Adam Barth <abarth at webkit.org> has denied Kentaro Hara <haraken at chromium.org>'s
request for review:
Bug 75082: REGRESSION(r102987): Fix the filename prefix of the generated empty
.h and .cpp files for [Supplemental] IDLs
https://bugs.webkit.org/show_bug.cgi?id=75082

Attachment 120314: Patch
https://bugs.webkit.org/attachment.cgi?id=120314&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=120314&action=review


> Source/WebCore/bindings/scripts/generate-bindings.pl:258
> +    my $prefix = "";
> +    if ($generator eq "JS") {
> +	   $prefix = "JS";
> +    } elsif ($generator eq "V8") {
> +	   $prefix = "V8";
> +    } elsif ($generator eq "ObjC") {
> +	   $prefix = "DOM";
> +    } elsif ($generator eq "GObject") {
> +	   $prefix = "WebKitDOM";
> +    } elsif ($generator eq "CPP") {
> +	   $prefix = "WebDOM";
> +    } else {
> +	   die "Unknown generator: $generator\n";
> +    }

Yuck!  Can we ask the generator what it's prefix should be rather than
hardcoding a list of all the generator subclasses?


More information about the webkit-reviews mailing list