[webkit-reviews] review granted: [Bug 74953] Avoid unnecessary work when removing attributes from an element : [Attachment 120093] Update setAttribute to use indices as well

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 20 15:04:24 PST 2011


Ryosuke Niwa <rniwa at webkit.org> has granted Adam Klein <adamk at chromium.org>'s
request for review:
Bug 74953: Avoid unnecessary work when removing attributes from an element
https://bugs.webkit.org/show_bug.cgi?id=74953

Attachment 120093: Update setAttribute to use indices as well
https://bugs.webkit.org/attachment.cgi?id=120093&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=120093&action=review


> Source/WebCore/dom/NamedNodeMap.cpp:263
> -void NamedNodeMap::removeAttribute(const QualifiedName& name)
> +void NamedNodeMap::replaceAttribute(size_t index, PassRefPtr<Attribute>
attribute)

Please re-odering these two functions if that improves the readability of diff.


More information about the webkit-reviews mailing list