[webkit-reviews] review granted: [Bug 74817] The scrolling coordinator should know about the main frame scroll layer : [Attachment 119773] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 18 12:23:39 PST 2011


Andreas Kling <kling at webkit.org> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 74817: The scrolling coordinator should know about the main frame scroll
layer
https://bugs.webkit.org/show_bug.cgi?id=74817

Attachment 119773: Patch
https://bugs.webkit.org/attachment.cgi?id=119773&action=review

------- Additional Comments from Andreas Kling <kling at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=119773&action=review


> Source/WebCore/page/ScrollingCoordinator.h:60
> +    // Should be called whenever the scroll layer for the given frame
changes.
> +    void setFrameScrollLayer(Frame*, const GraphicsLayer* scrollLayer);
> +
>      // Should be called whenever the geometry of the given frame changes,
>      // including the visible content rect and the content size.
>      void syncFrameGeometry(Frame*);

frameScrollLayerChanged() and frameGeometryChanged() might be better names for
these functions.


More information about the webkit-reviews mailing list