[webkit-reviews] review granted: [Bug 74646] sizeof(RenderObject) is 32 instead of 24 on Windows : [Attachment 119520] The patch that fixes all

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 15 17:10:01 PST 2011


Darin Adler <darin at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 74646: sizeof(RenderObject) is 32 instead of 24 on Windows
https://bugs.webkit.org/show_bug.cgi?id=74646

Attachment 119520: The patch that fixes all
https://bugs.webkit.org/attachment.cgi?id=119520&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=119520&action=review


Looks OK.

> Source/WebCore/rendering/RenderObject.h:899
> +#define ADD_BOOLEAN_BITFIELD(name, Name) \

Should probably #undef ADD_BOOLEAN_BITFIELD after the code that uses it since
it’s in a header.

> Source/WebCore/rendering/RenderObject.h:904
> +	   ALWAYS_INLINE bool name() const { return m_##name; }\
> +	   ALWAYS_INLINE void set##Name(bool name) { m_##name = name; }\

I think ALWAYS_INLINE is overkill. Normal inlining should be OK.

> Source/WebCore/rendering/RenderObject.h:973
> +	   // These bitfields are moved here from subclasses to pack them
together
> +	   // from RenderBlock

This “from RenderBlock” looks like a continuation of the comment on the line
before. A period would make it better. A blank line also would help.


More information about the webkit-reviews mailing list