[webkit-reviews] review denied: [Bug 74169] Upstream 3 files into WebCore/platform/blackberry : [Attachment 119132] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 13 19:14:10 PST 2011


Daniel Bates <dbates at webkit.org> has denied  review:
Bug 74169: Upstream 3 files into WebCore/platform/blackberry
https://bugs.webkit.org/show_bug.cgi?id=74169

Attachment 119132: Patch
https://bugs.webkit.org/attachment.cgi?id=119132&action=review

------- Additional Comments from Daniel Bates <dbates at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=119132&action=review


> Source/WebCore/platform/blackberry/PageClientBlackBerry.h:28
> +namespace Graphics {

Maybe adding an empty line about this line will make this namespace directive
stand out a bit more from the forward declaration of the class.

> Source/WebCore/platform/blackberry/PageClientBlackBerry.h:29
> +class Window;

This should be indented per (3) of Indentation of
<http://www.webkit.org/coding/coding-style.html>.

> Source/WebCore/platform/blackberry/PageClientBlackBerry.h:56
> +    virtual bool shouldPluginEnterFullScreen(WebCore::PluginView*, const
char* pluginUniquePrefix) = 0;
> +    virtual void didPluginEnterFullScreen(WebCore::PluginView*, const char*
pluginUniquePrefix) = 0;
> +    virtual void didPluginExitFullScreen(WebCore::PluginView*, const char*
pluginUniquePrefix) = 0;
> +    virtual void onPluginStartBackgroundPlay(WebCore::PluginView*, const
char* pluginUniquePrefix) = 0;
> +    virtual void onPluginStopBackgroundPlay(WebCore::PluginView*, const
char* pluginUniquePrefix) = 0;
> +    virtual bool lockOrientation(bool landscape) = 0;

pluginUniquePrefix => uniquePluginPrefix

We tend to place the adjective/verb before the noun in names. This follows from
(8) of section Names of <http://www.webkit.org/coding/coding-style.html>.


More information about the webkit-reviews mailing list