[webkit-reviews] review denied: [Bug 74033] Refactoring: SpellChecker::requestCheckingFor should take SpellCheckRequest object : [Attachment 118325] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 7 23:02:37 PST 2011


MORITA Hajime <morrita at google.com> has denied Shinya Kawanaka
<shinyak at google.com>'s request for review:
Bug 74033: Refactoring: SpellChecker::requestCheckingFor should take
SpellCheckRequest object
https://bugs.webkit.org/show_bug.cgi?id=74033

Attachment 118325: Patch
https://bugs.webkit.org/attachment.cgi?id=118325&action=review

------- Additional Comments from MORITA Hajime <morrita at google.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=118325&action=review


Basically looks fine. let's have one iteration.

> Source/WebCore/editing/SpellChecker.cpp:127
> +    request->setSequence(++m_lastRequestSequence);

Let us make sure that published id never conflict against the magic number. 
I know this will never happen in reality, but preventing it explicitly gives us
more confidence.

> Source/WebCore/editing/SpellChecker.h:66
> +    Element* m_rootEditableElement;

Let's make this RefPtr to prevent possible dangling pointer access.

> Source/WebCore/editing/SpellChecker.h:78
> +    static PassRefPtr<SpellCheckRequest> createRequest(TextCheckingTypeMask,
PassRefPtr<Range> checkingRange, PassRefPtr<Range> paragraphRange);

SpellCheckerRequest::create() is our standard way if there is no special
reason.


More information about the webkit-reviews mailing list