[webkit-reviews] review granted: [Bug 68617] When page scaling is in use position:fixed has incorrect results : [Attachment 113486] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 1 10:43:59 PST 2011


Simon Fraser (smfr) <simon.fraser at apple.com> has granted  review:
Bug 68617: When page scaling is in use position:fixed has incorrect results
https://bugs.webkit.org/show_bug.cgi?id=68617

Attachment 113486: Patch
https://bugs.webkit.org/attachment.cgi?id=113486&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=113486&action=review


> Source/WebCore/page/FrameView.h:415
> +    bool m_shouldLayoutFixedElementsRelativeToFrame;

Please group this with other bools to optimize packing.

> Source/WebCore/rendering/RenderBox.cpp:2334
> +    Frame* frame = view() ? view()->frame(): 0;
> +    FrameView* frameView = view() ? view()->frameView() : 0;
> +    if (style() && style()->position() == FixedPosition &&
container()->isRenderView() && frame && frameView &&
frameView->shouldLayoutFixedElementsRelativeToFrame())

There has to be a way to make this (duplicated twice) code less ugly. Maybe
move it to an inline function?


More information about the webkit-reviews mailing list