[webkit-reviews] review denied: [Bug 73458] [GTK] Add compilation options to enable/disable Accelerated Compositing and to choose texture mapper implementation. : [Attachment 117384] Option to choose AC method to use

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 1 05:03:38 PST 2011


Alejandro G. Castro <alex at igalia.com> has denied Nayan Kumar K
<nayankk at motorola.com>'s request for review:
Bug 73458: [GTK] Add compilation options to enable/disable Accelerated
Compositing and to choose texture mapper implementation.
https://bugs.webkit.org/show_bug.cgi?id=73458

Attachment 117384: Option to choose AC method to use
https://bugs.webkit.org/attachment.cgi?id=117384&action=review

------- Additional Comments from Alejandro G. Castro <alex at igalia.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=117384&action=review


Looks good, just some suggestions.

> Source/WebCore/GNUmakefile.am:568
> +if !USE_AC_CLUTTER

I've rather used the positive condition in this case, I think it is safer,
actually you can probably remove the previous if and just check if
USE_AC_TEXTURE_MAPPER_OPENGL || USE_AC_TEXTURE_MAPPER_OPENGL, in future patches
we could add the proper layout if there is another options in the if.

> Source/WebCore/GNUmakefile.list.am:5078
> +if !USE_AC_CLUTTER

Same here.

> Source/WebCore/platform/graphics/GraphicsLayer.h:77
> +#if !USE(AC_CLUTTER)

Same here

> configure.ac:401
> +if test "$enable_webgl" = "yes" ||  test "$with_accelerated_compositing" =
"clutter" || test "$with_accelerated_compositing" = "texmap-cairo"  || test
"$with_accelerated_compositing" == "texmap-opengl" ; then

In case of clutter shouln't we check clutter library instead of GL?

> configure.ac:1160
> +AM_CONDITIONAL([USE_AC_CLUTTER], [test "$with_accelerated_compositing" =
"clutter"])
> +AM_CONDITIONAL([USE_AC_TEXTURE_MAPPER_OPENGL], [test
"$with_accelerated_compositing" = "texmap-opengl"])
> +AM_CONDITIONAL([USE_AC_TEXTURE_MAPPER_CAIRO], [test
"$with_accelerated_compositing" = "texmap-cairo"])

I think abbreviations are not used in the defines to improve readability, even
if we have a huge name, not sure if we can use just a part of it.


More information about the webkit-reviews mailing list